Resolved
The issue has been resolved!
Monitoring
We have deployed the fix and are now testing it.
Identified
We have started deploying the fix. Will keep this channel updated.
Identified
We now have a fix and are applying it.
Investigating
The budget editor is not working. We have identified the problem and a fix is in progress.